Layer-3-Fähigkeit auf einem Cisco Small Business SG300 (=SRW2024)


sehr verwirrender ArtikelNaja, ganz OKbrauchbar für Checker...guter Artikelsehr guter Artikel - Danke

Die Switches der Reihe SG 300 (von 8 bis 52 Ports erhältich) sind Layer-3 fähig, dh, sie können als Router verwendet werden, um zwischen VLANs zu routen – und dies zu einem sehr günstigen Preis!

Leider (?) wird auf diesen Switches aber per default das Routing NICHT aktiviert, dh, wenn dies nicht explizit aktiviert wird, funktionieren die Switches dieser Baureihe “nur” auf Layer 2 Ebene.

Und dann gäbe es da noch einen Stolperstein:
Die Routingtabelle (im CLI show ip route bzw. in der GUI IP Configuration // IPv4 Static Routs) zeigt nur jene Routen zwischen den VLANs an, in denen auch tatsächlich Clients hängen… sprich: solange man nur mit einem einzigen Client die Interfaces anlegt, erscheint in der Routingtabelle auch nur dieser eine Eintrag. ARGHHH

Vorgangsweise, um den Routing-Modus auf einem SG 300 zu aktivieren

ich gehe im Folgenden davon aus, dass ihr die IP-Adresse etc bereits richtig vergeben habt…

1.) Telnetzugang zum Switch in der GUI aktivieren:

2. per Telnet mit dem Switch verbinden

nun muss unterschieden werden, welche Firmware am Switch vorhanden ist
a) noch eine ältere Firmware ohne CLI
b) eine neuere Firmware mit CLI

a) es ist noch eine ältere Firmware vorhanden:

ACHTUNG: die Leertaste dient der Auswahl, mit Escape kommt man wieder zurück

b) es wurde bereits ein Update der Firmware durchgeführt = CLI ist vorhanden

In nachfolgendem Screenshot wurde bereits zuvor auf den Router-Mode umgestellt. Beim erstmaligem Umstellen ist ein Reboot des Switches erforderlich, der automatisch vom System vorgenommen wird!

switch_test# login
User Name:edi
Password:*****
switch_test#

switch_test# set system mode router {router | switch}

switch_test# show system mode
Feature State
——————- ———
Mode: Router
Qos: Active
Policy-based-vlans: Active

___________________________________________________________________

Anmerkung, damit ichs nicht vergesse: “Reset to factory defaults”: Switch vom Netzwerk trennen und in eingeschaltetem Zustand die Reset-Taste an der Frontseite länger als 10 Sekunden gedrückt halten.

Factorydefaults: 192.168.1.254/24 –> user cisco ; pass cisco

bei dieser Gelegenheit sie noch erwähnt:

hier findet man ein paar Zeilen fürs CLI, um VLANs anzulegen und Interfaces zu definieren:
https://supportforums.cisco.com/thread/2101709

es gibt einen verständlich gemachten Demo-Guide für die GUI:
https://supportforums.cisco.com/docs/DOC-13844

es gibt eine Online-Emulation der GUI und CLI:
https://supportforums.cisco.com/community/netpro/small-business/onlinedemos



Ein Hinweis an dieser Stelle in eigener Sache:
Nehmen Sie sich bitte etwas Zeit und werfen einen Blick auf unser Tool "ADMINOMAT",
das aus unseren vielen Erfahrungen mit dem Thema Netzwerk und Active Directory im Laufe der letzten Jahre entstand

This entry was posted in Netzwerk, VLAN. Bookmark the permalink.

10 Responses to Layer-3-Fähigkeit auf einem Cisco Small Business SG300 (=SRW2024)

  1. Christian says:

    Hallo Edi,
    habe gerade versucht den SRW 2024 von Linksys in den Router Modus zu schalten, leider klappt dies nicht.
    Da der Router schon über 3 Jahr alt ist, gehe ich davon aus das es hier bereits baureihenbedingte Unterschiede gibt.
    Bei folgendem Router geht es nicht :
    Linksys SRW2024 V.1.2
    Wenn ich dort die Befehle eingebe, erscheint leider nur Bad Command, es ist die letzte Firmware installiert. ( FW 1.2.2b 28-FEB-2008 )

  2. Johannes says:

    Hallo,

    wollte meinen SG300 zum Routen bringen. Leider kennt das CLI im Config-Mode den “set”-Befehl nicht.
    Firmware ist auf aktuellem Stand. Ist der Tipp noch aktuell?

    Freue mich auf ein Feedback. Danke!

  3. Edi Pfisterer says:

    Hallo!
    Mein Artikel enthielt einen Fehler (ich habe die Befehle – ohne zu Testen – aus meiner Erinnerung zusammengebastelt…)
    Ich bitte Euch aufrichtig um Entschuldigung, tut mir wirklich leid – ich weiss, wie ärgerlich falsche Informationen sein können!
    Ende gut, alles gut?!:
    Nun stimmt die Befehlsreferenz, ich habe sie auch so getestet (siehe Screenshot).
    Gutes Gelingen Euch beiden!
    lg
    Edi

  4. Johannes says:

    Hallo,

    danke, so funktioniert es :)

  5. Christian says:

    Also ich kann machen was ich will, der Router kennt die Befehle nicht.
    Ich werde mir wohl dann doch 2 x SG 300 besorgen, sind denn alle SG 300 Routing fähig ?

    • Edi Pfisterer says:

      Hallo Christian!
      Versuche mal, nach erfolgreichem Login ein “?” einzugeben –> da sollte dann die Befehlsreferenz erscheinen;
      entsprechend gibt ein “set ?” alle Erweiterungen für den Befehl set aus

      Falls es Dir gelingt, den Switch umzukonfigurieren, wäre es nett, wenn Du hier den passenden Befehl posten könntest…

      gutes Gelingen,
      lg
      Edi

  6. sr256 says:

    set system mode router
    gerade erfolgreich auf dem SG300-10p getestet.

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht.


*

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>